This page is printed from WorleyParsons.com

 

Microsoft Silverlight Software Requirements 

To register with WorleyParsons Supplier Portal, Microsoft Silverlight version 5.1 is required. The application will prompt you to install the correct component if it is not already installed on your computer
©2008 - 2012 WorleyParsons Ltd